Home / products / labtracer

 

LabTracer Test Integration Software

Document Actions
LabTracer Test Integration Software. Version 2.7 download and installation information.
Keithley Instruments Inc. 2007

LabTracer 2.0
Release Notes for Version 2.7
LabTracer 2.0 Test Integration Software
1-November-2007


This document provides additional information for the installation and use of the LabTracer 2.0 Software.

Section 9 contains update information from version 2.43
Section 10 contains update information from version 2.5 to 2.6
Section 11 contains update information from version 2.6 to 2.7



1 Introduction

LabTracer 2.0 is a software example for characterizing components using Keithley SourceMeters and Series SourceMeters in a research environment. LabTracer 2.0 is SourceMeter example software provided 'as is'. There is no guarantee of service or warranty implied or stated. For more information on our products, support, and information please contact us at www.keithley.com.
Keithley LabTracer 2.0 Software makes it easy to build tests for the Keithley Series 2600, Series 2400, and Model 6430 SourceMeters using a GUI interface. The software runs on a PC and communicates with your instrument using a GPIB interface. The software is an easy to use, yet powerful graphical development environment for integrating different instruments into a single test or building test scripts for use in Series 2600 SourceMeters.

2 System Requirements

Pentium III, 800 MHz class PC or better
200 MByte free disk space
Supported GPIB controller (See section 2.2) for communications with the instrument.
NOTE: It is strongly recommended that your computer and instrument be powered by an Uninterruptible Power Supply (UPS) when running a critical application.

2.1 Tested Operating Systems

Windows XP Professional service pack 2 or later
Windows 2000 service pack 4 or later
Windows NT 4 service pack 6a or later
Windows 98 Second Edition only

NOTE: Neither Windows 95 nor Windows ME have been tested.

2.2 Tested GPIB Controllers
You must have a compatible GPIB controller card and associated software driver installed in your computer to run tests with LabTracer 2.0 software.
LabTracer 2.0 software has been successfully tested with the following GPIB controllers:
Keithley Instruments GPIB cards (ISA, PCI)
CEC GPIB cards (ISA, PCI)
National Instruments GPIB cards (ISA, PCI, PCMCIA, USB)
Keithley Instruments KUSB-488 USB to GPIB adaptor

3 Installation

3.1 Keithley LabTracer 2.0 Installation
If you have an earlier version of the software installed on your computer, the installation routine will detect and uninstall it. You will have to run setup.exe twice (once to uninstall the old version and once to install the new version).
LabTracer 2.0 software can be downloaded from www.keithley.com

3.1.1 Installing from the Web
Download the LabTracer 2.0 Software from the Keithley Web site, www.keithley.com . The suite is a single file, approximately 70 MB in size, and should be downloaded to a temporary directory on your computer.
Run the downloaded file from the temporary directory.
As the software installs, you will be presented with a series of windows dialog boxes asking you to make decisions about how the software is installed. For most users, it is recommended that all the default options be accepted. Advanced users may customize the installation as desired. Depending on your computer’s operating system and configuration, the installation utility may prompt you to reboot your computer during the installation process.

The LabTracer 2.0 download will automatically install LabTracer 2.0, but to run tests several other components may be needed. Some are included in the self-expanding archive and are unzipped when LabTracer 2.0 is installed. A list of these components and tips for their installation are below.

NOTE For Series 2600 SourceMeter users: If you have installed the Test Script Builder Suite software it has installed all software components necessary to run LabTracer 2.0 including the Microsoft .NET framework version 1.1 and NI VISA layer. Installing LabTracer 2.0 alone will work assuming your GPIB card is correctly communicating with Test Script Builder.

3.2 NI (National Instruments) VISA RUNTIME 3.01
To install the NI VISA Runtime double click visa301runtime.exe from the self expanding archive and follow the instructions.

WARNING:

Installing this VISA Runtime may cause issues with other programs if you have a previous version of VISA you are using (especially if it is from a different manufacturer) or if you are using a GPIB card in some configurations without VISA. To avoid incompatibilities and other problems we strongly suggest that you not install this VISA runtime unless it is absolutely necessary. Try installing LabTracer 2.0 and running a test. Running a test and receiving an error as described in section 6 below that says your VISA layer is not installed or incompatible with LabTracer 2.0 is the best way to determine if you need this update. If you are concerned about this possibility contact Keithley Instruments support for more information before proceeding.

NOTE For Series 2600 SourceMeter users: If you have installed the Test Script Builder Suite software it has installed all software components necessary to run LabTracer 2.0 including the Microsoft .NET framework version 1.1 and NI VISA layer. Installing LabTracer 2.0 alone will work assuming your GPIB card is correctly communicating with Test Script Builder.

3.3 GPIB Controller and Driver Installation

If you will be using GPIB to communicate with your instrument, you must have a compatible GPIB controller card and associated software driver installed in your computer before using LabTracer 2.0 software.
Install the GPIB controller and associated driver by following the instructions supplied with the controller. Most GPIB controllers provide a function or utility to allow testing the controller and connection to the instrument. We recommend that you verify correct operation of the GPIB controller before running LabTracer 2.0 software.
The latest driver for CEC’s PCI and USB GPIB cards is included in the LabTracer 2.0 archive along with release notes. Complete information as well as latest drivers for all of CEC’s GPIB interfaces is available at www.cec488.com.
Typically, whatever version of NI VISA you are running will contain drivers for your NI GPIB cards. Also, typically an acceptable version of VISA will be installed when you install a new NI GPIB card. For complete information on getting your NI GPIB card working with VISA go to www.ni.com.

IMPORTANT NOTE: Because VISA may install drivers for NI GPIB cards installing this may overwrite current GPIB drivers. Therefore, if you are using a CEC or other VISA compatible GPIB card not made by NI you may need to install the GPIB drivers AFTER installing the VISA Layer. This is the order of operations we would suggest for each configuration:
-If GPIB is already working with VISA on your pc:
Install only LabTracer 2.0 then try a test. You may still need to update the .NET Framework to version 1.1 (see section 3.4 below)
-If no VISA layer is currently installed:
-If you have a NI GPIB card already installed:
Install LabTracer 2.0 and install the NI Visa Runtime (see sections 3.1 and 3.2 above), Order of installation should not matter. You may still need to update the .NET Framework to version 1.1 (see section 3.4 below)
-If you have a non-NI GPIB card already installed:
Make certain you have a copy of the driver for your GPIB card. Install LabTracer 2.0 and the NI Visa Runtime (see sections 3.1 and 3.2 above). Now you may need to reinstall your GPIB card driver, but you can test LabTracer 2.0 before reinstalling to see if it is working. You may still need to update the .NET Framework to version 1.1 (see section 3.4 below)
-If VISA is already installed, but not your GPIB card:
Install your GPIB card and LabTracer 2.0. You may still need to update the .NET Framework to version 1.1 (see section 3.4 below)
-If neither VISA nor the GPIB interface is currently installed
Install the NI Visa Runtime (see section 3.2 above), your GPIB card, and LabTracer 2.0. You may still need to update the .NET Framework to version 1.1 (see section 3.4 below)

3.1 Microsoft .NET Framework Version 1.1 Installation

The Microsoft .NET framework version 1.1 allows the LabTracer 2.0 run time test engine to run because it is encapsulated in a .NET project. If your .NET Framework is not installed or is too old of a version you may receive a warning message to that effect when starting LabTracer or when running tests in standard mode the window labeled “LabTracer 2 Run Time Engine Status” will never appear and a test will never actually run. You can also verify this and see the actual error by running the program in the LabTracer2 install directory under LabTracer2\data\bin\luaRTE.exe. Running this will show the exact warning or run a test.

If you determine that you require an updated .NET Framework in one of these ways the easiest way to update is to go to WINDOWS UPDATES. Scan for updates and install at least the components named .NET Framework. This is a free update service from Microsoft.

NOTE For Series 2600 SourceMeter users: If you have installed the Test Script Builder Suite software it has installed all software components necessary to run LabTracer 2.0 including the Microsoft .NET framework and NI VISA layer. Installing LabTracer 2.0 alone will work assuming your GPIB card is correctly communicating with Test Script Builder.

3.2 Uninstalling LabTracer 2.0
To COMPLETELY uninstall LabTracer 2.0 run the downloaded file again or use Add/Remove Programs in the Control Panel. Below is a list of other software components that LabTracer 2.0 depends on that may need to be installed with LabTracer 2.0 and which you may want to uninstall when removing LabTracer 2.0

IMPORTANT: Software installed before LabTracer 2.0 may share some of the software components used by LabTracer 2.0. Therefore, removing these shared components may cause system instability. These shared components are identified below, along with a brief description of how they are shared.


  • Microsoft .NET Framework version 1.11
  • National Instruments VISA Runtime 2

NOTES: 1 – Software developed using Microsoft .NET tools depend on this.
2 – Various software products from National Instruments depend of this.

4 Using LabTracer 2.0

To launch LabTracer 2.0 select Start>>Programs>>Keithley Instruments>> LabTracer 2.0.
Also in the Keithley Instruments directory is a file called LabTracer2 Help Demo. This is a video presentation to help you learn and use LabTracer 2.0.

5 Known Problems, Issues, Quirks, and Concerns


  1. The Series 2600 SourceMeters have a prompting mode controlled by the command “localnode.prompts = 1” or 0 (on or off). Programs like Test Script Builder turn on this prompting feature. In some cases LabTracer 2.0 can not successfully bring the instrument out of prompting and it may not respond correctly to run tests. To fix this error power cycle the Series 2600 between using it for Test Script Builder and LabTracer 2.0.
  2. The Series 2600 SourceMeters use a communication called TSPLink that allows them to communicate across “nodes”. Because LabTracer 2.0 allows the use of multiple instruments across different nodes it will always verify the node number when starting a test. These node numbers must be different for each instrument on a TSPLink system and they must match the Node Numbers set in LabTracer 2.0, else LabTracer 2.0 will be unable to locate the correct instrument. This is like the GPIB addressing system. For a 2400 SourceMeter the GPIB address and interface card number set in LabTracer 2.0 must match the settings on the instrument. For a 2600 Series SourceMeter the GPIB address, interface card number, AND TSPLink node must all match.
  3. LabTracer 2.0 does not save previous settings when the user changes the Instrument Function or the Instrument Model from the GUI Interface. This means that settings such as GPIB address, sweep points, SMU Channel Designation, NPLCs, and others will be reset if you are switching from “Sweep Voltage” to “Sweep Current”. This is just something to be aware of.
  4. On some older computers LabTracer 2.0 may run slowly. The slowest might include launching the Run Time Engine Status Window when running a test and launching the Instrument Setup window. If slower operation concerns you see section 2 for minimum system requirements.
  5. Occasionally, while running a test you may see a pop-up window asking if you want to replace the data.txt file. This file is where current data is being stored from your test. The file is being programmatically deleted and replaced whenever new data is received. Occasionally, the OS may not delete the file in time and this warning could pop up. Just click REPLACE or hit ENTER to continue with your test.
  6. On some systems some fonts will appear too large and may not fit on the panel space allocated for them. We have not found this to affect usability in many cases. Typically, the problem can be solved by setting display properties appearance to an appearance with a standard size.
  7. When using the CLOSE (x) in the top right of the LabTracer 2.0 application window the program exits abruptly. Users will not get a “Do you want to save first?” prompt and other windows that are open in LabTracer 2.0 will stop functioning but remain open and need to be closed individually. To avoid this use FILE menu -> EXIT function instead.

6 Trouble Shooting Tips


CAN'T RUN A TEST - THE DATACENTER APPEARS, BUT IT DOESN'T TALK TO THE INSTRUMENT AND I DON'T GET AN ERROR.

If you try to run a test in Standard Mode (RUN AUTOMATED TESTS button on the Advanced Setting screen UNCHECKED OR using an instrument other than a 2600 series SourceMeter) and the little window labeled "LabTracer 2.0 Run Time Engine Status" (you can see what this looks like in the walk through demo if you are unsure) never appears then the .NET framework is not able to start up the run time engine. Users can confirm this by going into the LabTracer 2.0 directory default is Program Files/LabTracer2/data/bin/. In this bin folder double click a file called luaRTE.exe. This will either run or throw an error explaining why it could not be launched. The error can usually be fixed by making sure the .NET framework is up to date. A warning at startup of LabTracer 2.0 may also warn users that this may be an issue.


WHEN I TRY TO RUN A TEST I GET AN ERROR ON VISA START OR VISA OPEN.

If the error is on VISA OPEN and the error code ends in 7339, then this is a timeout error. This means that the VISA and GPIB layers are installed correctly, but the instrument did not respond at the expected address. Verify the address setting in the instrument setup panel, verify the address on the instrument, and make sure the cables are connected between the instrument and the card. If you have more than one GPIB card in your system make sure the board # at the top of the Instrument setup panel is correct. If you have only one GPIB card this number should probably be zero unless you have set it to something else on purpose. If the error is on VISA OPEN or VISA START and the error code does NOT end in 7339, then you probably need to reinstall the VISA layer or the 488.2 driver for your GPIB card.

If you have any questions about these issues please call Keithley Instruments support staff.


WHEN I RUN A TEST I GET AN ERROR STATING THAT AN INSTRUMENT COULD NOT BE FOUND.

Check to see if the “REM” remote indicator light on the instrument front panel is on. If so, then check the instrument model number and make sure the model number matches the instrument you are using in LabTracer 2.0. Even for instruments with overlapping capabilities like a Model 2400 and Model 2420 LabTracer 2.0 checks the model number before running a test and will stop the test if it does not find the correct model number. If the “REM” indicator is not on make sure the GPIB addresses match in LabTracer 2.0 and on your instruments. Also verify the cabling between the PC and the instrument. Also verify that the instrument is set to communicate in GPIB (488.2 if applicable) mode. If the test still does not run test your instrument communication with a utility that came with your GPIB interface card because you may be unable to communicate through your GPIB card. From this utility you should be able to verify the VISA board number that is being used by your interface card.


WHEN I RUN A TEST I GET AN ERROR STATING THAT THE TSPLINK NETWORK COULD NOT BE RESET.

This only applies to Series 2600 SourceMeter users. This error means that your instrument’s TSPLink “node number” does not match the number set in LabTracer 2.0 in the Instrument Setup Window on the Advanced Tab. LabTracer 2.0 then tried to reset the TSP network to find a different node. Check your Model 2600 Series Manual on how to view and set the node number. These numbers must match between LabTracer 2.0 and the instrument to successfully run tests.


IN ADVANCED TEST MODE NOTHING HAPPENS WHEN I RUN A TEST.

LabTracer 2.0 runs in advanced mode only for Series 2600 SourceMeters. If the test does not run, you probably have a communication issue listed above that the advanced test engine takes for granted. To stop a test that is not operating click on ABORT or ABORT TEST on the active test window. To turn on or off advanced testing mode, Click on ADVANCED SETTINGS on the right of the toolbar and check or uncheck the box for automated testing with 2600 Series SourceMeters. To debug this error abort the test, turn off advanced (automated) testing, then run the test in standard mode. Read the error you receive and follow the tips listed above that apply.



7 End User License Agreement Text


LabTracer 2.0 is SourceMeter example software provided 'as is'. There is no guarantee of service or warranty implied or stated.

By Clicking YES below I agree that I have read and understood the document LabTracer2_Release_Notes.htm that was available for download from www.keithley.com. A copy is included in this install pack for later reference. Review this document for complete installation directions and system requirements.

By Clicking NO I do not agree and choose not to install LabTracer 2.0.


8 Copyright Notice


LabTracer 2.0 components Licensing information

LuaInterface License
--------------------
LuaInterface is licensed under the terms of the MIT license reproduced below. This mean that LuaInterface is free software and can be used for both academic and commercial purposes at absolutely no cost.
===============================================================================

Copyright (C) 2003, 2004 Fabio Mascarenhas de Queiroz. Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in
all copies or substantial portions of the Software. THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

For further assistance call Keithley Instruments toll free at 800-552-1115 or log on to www.keithley.com and click contact us to reach applications support via the web.

LabVIEW Copyright information
-----------------------------

VISA software supplied with LabTracer 2.0 is © Copyright 2005 National Instrument Corporation. All rights reserved.


9 Updates from previous version (2.43)


updated 2602 data sheet, manual, and brochure help documents to newest versions

ADDED 2430 Instrument (PULSE & DC Functions) – Includes Pulsed V Sweep and Pulsed I Sweep

ADDED 2611 Instrument (PULSE & DC Functions) - Includes Pulsed V Sweep, Pulsed I Sweep, Pulsed V Step, Pulsed I Step, Pulsed Continuous V Sweep, Pulsed Continuous I Sweep

ADDED 2612 Instrument (PULSE & DC Functions) - Includes Pulsed V Sweep, Pulsed I Sweep, Pulsed V Step, Pulsed I Step, Pulsed Continuous V Sweep, Pulsed Continuous I Sweep

ADDED Default test projects for 2612

ADDED popup & wait between tests – This creates a pause between tests when you are set to do multiple tests. It presumes you would like to change something external to LT2 between tests.
caveats: In standard mode a popup on screen appears. Click OK to go to next test. In advanced Mode, a prompt appears on the master unit. Push any button to continue test. This feature can not be disabled. New version ALWAYS pauses between tests. Use cases lead us to believe that repeat test makes no sense without pausing.

ADDED JPG graph save as function on DataCenter

FIX On 6430 trying to source 1 pA would not work Converted the units in Current to a separate input.

IMPROVED Data Center Data Table so it will more often reset the data sheet to the top left so you see the early data coming into the sheet.

FIX Removed Moving Averages from all instruments. In the context of a sweep or step a moving average does not make sense and could cause data skew. Use repeat filtering for best results. Also 6430 filter settings were changed to remove the median filter and auto filter options for the same reasons.

FIX autosource range in LOG SWEEP/STEP – You can now autorange the source values during a log sweep or step making the source values more accurate.

FIX added setting for 6430 Lower limit to autorange. The default setting of 1 pA range (no low auto limit) caused some problems in some test environments. For best low current results leave this on 100 pA as the lowest range that autorange will go to.

FIX inability to change Graph setup on some systems

FIX edit properties to disallow run-time short-cut menus which should not be user accessible

FIX made it more difficult to accidently hit run test twice before it is locked out and get an error in return.

FIX Issue from PCs using a comma instead of a decimal in numbers has been resolved.

FIX made more of the program text Arial so that using an uninstalled font does not create misshaped GUIs

FIX graph definition and tools window titles updated

NEW INFORMATION on Pulse functions:

The pulse functions allow you to pulse in a sweep mode with a 2430 in voltage or current while measuring. These pulse features can be intermingled with DC and standard Pulse functions on multiple channels. In these tests multiple pulses happen in SERIES as do any measurements from different channels.

The standard sweep and step I and V functions for the 2611 and 2612 work similarly. They allow the integration of other DC and pulse channels and measurements into the test.

The Pulsed Continuous I and V Sweeps are used for deterministic off times in pulse trains. These functions run the pulses back to back at high speeds and can coordinate only with one other SMU in the same 2612 chassis. To achieve these speeds it is not possible to sweep or measure on any other channels during a 1 channel or 2 channel Continuous pulse setup.

To coordinate dual channels in pulse modes on the 2612 requires careful consideration. Both channels must have the same off time and NPLC setting. One channel must have an on time at least 50 usec longer than the other. The IV envelope for pulsing is also unique. LabTracer 2 will show errors during a test if the pulse configuration is invalid. For complete information on pulsing limitations read your manual.

None of the 2611 or 2612 Pulse functions can be done over TSPLink. Instruments must be connected directly over GPIB.


10 Updates from previous version (2.5)


ADDED instrument functions for Models 2425, 2635, and 2636.

EXPANDED instrument popup to show new models.

FIXED some known bugs in the 2612 instrument drivers have been removed.

WARNING: The small fixes to the 2611 and 2612 drivers effect some operation, but because they were small and not directly related to the 2612 Example programs the examples were not updated. This means that if you open a 2612 example and start editing it you are still using the old instrument driver that was saved with that test. To update any saved test to the latest driver simply note your settings and select a different instrument and then back to the instrument you want to use. This reloads the latest driver. Now input your desired settings and resave the test.


11 Updates from previous version (2.6)


REBUILD to include missing changes to 2611 and 2612 driver previously released.



 
PRODUCT SEARCH
To search for products, please enter the
keyword(s) and click Go: